Issue with manual trading
Incident Report for Altruist
Resolved
This issue has been resolved and all trading has been restored.
Posted Mar 24, 2023 - 15:16 UTC
Investigating
We're investigating an issue with the inability to place a manual trade.
Posted Mar 24, 2023 - 14:02 UTC
This incident affected: Advisor Portal.