TWR updates
Incident Report for Altruist
Resolved
This incident has been resolved.
Posted Oct 26, 2023 - 00:09 UTC
Identified
We are releasing an update to TWR today, Oct 25th, which will complete by 12 PM PST. TWR values may temporarily be inconsistent until the update is complete. Please delay generating Investment Summary Reports until after 12 PM PST.
Posted Oct 25, 2023 - 16:23 UTC
This incident affected: Advisor Portal and Client Portal.