Issue with manual trading
Incident Report for Altruist
Resolved
This incident has been resolved.
Posted Jul 17, 2023 - 18:29 UTC
Update
Manual trading has been restored. We appreciate your patience as we worked with our upstream provider to fix the issue.
Posted Jul 17, 2023 - 14:57 UTC
Update
We are continuing to investigate this issue.
Posted Jul 17, 2023 - 14:42 UTC
Update
We are continuing to investigate this issue.
Posted Jul 17, 2023 - 14:04 UTC
Investigating
Altruist is experiencing a temporary outage with manual trading and rebalancing. We are working to restore these services as quickly as possible.

Mutual fund pricing data has been restored.
Posted Jul 17, 2023 - 13:50 UTC
This incident affected: Advisor Portal.