Platform login issues
Incident Report for Altruist
Resolved
The issue has been resolved.
Posted Jun 30, 2023 - 15:17 UTC
Investigating
We are investigating an issue that's impacting the advisor and client portals. We will provide an update in 30 minutes.
Posted Jun 30, 2023 - 14:56 UTC
This incident affected: Advisor Portal and Client Portal.