Issue with trading fractional shares
Incident Report for Altruist
Resolved
Fractional trading has been restored.
Posted Mar 24, 2023 - 18:13 UTC
Update
We are continuing to investigate this issue.
Posted Mar 24, 2023 - 17:35 UTC
Investigating
We are investigating an issue impacting the ability to trade fractional shares.
Posted Mar 24, 2023 - 16:55 UTC
This incident affected: Advisor Portal.