Degraded Performance

Incident Report for Altruist

Monitoring

Mitigation efforts remain underway. We continue working toward fully restoring service.

The team continues monitoring.
Posted May 08, 2026 - 01:36 PDT

Identified

We are observing early signs of recovery. We continue to work towards fully restoring service
Posted May 07, 2026 - 23:23 PDT

Investigating

We are aware that customers may be experiencing degraded performance at this time due to an AWS outage. Our team is investigating this issue and will provide an update.

For more information, view the status of https://health.aws.amazon.com/health/status
Posted May 07, 2026 - 20:38 PDT
This incident affects: Advisor Portal, Client Portal, and Marketing Portal.