Third-Party Incident Impacting System Availability

Incident Report for Altruist

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 02:27 UTC

Monitoring

A fix has been implemented and we are monitoring the results
Posted Oct 21, 2025 - 02:23 UTC

Investigating

Some areas of the Altruist platform may not be functioning as expected due to a disruption with one of our third-party service providers. You may notice delays or limited access to certain features.
Posted Oct 20, 2025 - 14:12 UTC
This incident affected: Advisor Portal, Client Portal, and Marketing Portal.