Hazel - Customer Login Unavailable

Incident Report for Altruist

Resolved

Root cause was identified and a fix applied.
Posted Feb 26, 2026 - 07:40 PST

Investigating

All customers with Altruist accounts are currently unable to log in.
Posted Feb 26, 2026 - 07:13 PST
This incident affected: Hazel AI.